Sign in to follow this  
turbomattk

Squeal in LF

5 posts in this topic

turbomattk    0

I have a squeal in the left front area of my 02 Grand Prix GT. It usually happens when I am in a straight line, sometimes it goes away when I turn to the left or right, sometimes it doesn't. I researched and think that it might be the CV joint or bad wheel bearing. This sound right? And how difficult is it to fix this? Thanks,

-mk

Share this post


Link to post
Share on other sites

CV axles would make more a clunking sound. The wheel bearing would possibly squeal. Easy way to check, jack up the wheel in question, grab the tire and check to see for any free-play at the wheel. If you get a whole lot, replace the hub assembly.

As far as replacing the hub assembly, remove the wheel, remove the spindle nut, remove the caliper and caliper bracket, remove the brake rotor, remove the three mounting bolts holding the hub assembly on, unplug the ABS wheel speed sensor, slide the hub assembly off the axle, slide the new hub on, reverse procedure.

Share this post


Link to post
Share on other sites

76 does his own maintenance... 8)

Share this post


Link to post
Share on other sites
Buickfosure    0

Possible brake noise you should pull the wheel and investigate make sure no crap is wedged in there or the pad might be not properly attached and shimed.

Edited by Buickfosure

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this