Sign in to follow this  
Followers 0
carman21

Does anybody have any suggestions?

3 posts in this topic

My 2000 Buick Regal LS has Dual Zone Climate Control, however, recently the system stopped working properly.

When I have the A/C on in the regular mode only heat comes out. When the Dual mode is on, only the passenger side is cold, and again the driver's side comes out hot.

Does anybody know what is going on with my car and ,if possible, how to fix it?

I just got off my warantee so I'd prefer to know what's wrong before I pay somebody to fix if its beyond my ability to fix it.

Well, any and all suggestons will be appreciated.

0

Share this post


Link to post
Share on other sites

I'm throwing a guess out here, but it could be a temp sensor...

It doesn't seem to be able to tell the difference between AC and heat.

0

Share this post


Link to post
Share on other sites

Actually, it sounds like the blend door actuator is stuck in the "heat" position and is only allowing air to pass by the heater core and then go to the driver's side of the vehicle. You can replace the actuator, but it WILL normally require tearing the entire dash apart.

0

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Loading...
Sign in to follow this  
Followers 0