Sign in to follow this  
Followers 0
1990Suburban

Truck lags when accelerating after refueling.

4 posts in this topic

So the last two times I've fueled up my truck it will lag out for a second when accelerating after being stopped at a stoplight. The first time it did it it was about 15 miles after I had filled up and lagged at two stoplights one right after another then was fine until the next fill up. This last time it did it about 20 miles after filling up and lagged out at three stops one right after another then was fine. I just replaced the fuel filter about 2,000 miles ago. Anyone think it could already be clogged or do you think my fuel injectors or fuel pump is bad?

0

Share this post


Link to post
Share on other sites

Was it really low when you filled up? Maybe you sucked some junk up into the filter from the bottom of the tank. It does have a steel tank on it. Just a guess.

0

Share this post


Link to post
Share on other sites

anyone think a concentrated bottle of fuel cleaner could be a cheap place to start?

0

Share this post


Link to post
Share on other sites

That would probably be a good solution, might have a little water in the bottom of the tank and the cleaner should clear it up.

0

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Sign in to follow this  
Followers 0