Jump to content
Sign in to follow this  
Gizhost

2002 Impala: Shifter button stuck.

Recommended Posts

Anyone ever heard of this? A friend of mine is having this problem. He couldn't get the car into park, he muscled the button in and got it into park and now he can't get it back out of park. Something is obviously broken but has anyone experienced this and do you know a work around so he can drive the thing to the dealer?

Share this post


Link to post
Share on other sites

The button mechanism is probably pooched, it happened on my Cavalier a few years ago, the button mechanism just needed to be replaced.

Share this post


Link to post
Share on other sites
The button mechanism is probably pooched, it happened on my Cavalier a few years ago, the button mechanism just needed to be replaced.

:yes:

Share this post


Link to post
Share on other sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



About us

CheersandGears.com - Founded 2001

We ♥ Cars

Get in touch

Follow us

Recent tweets

facebook

×
×
  • Create New...