Sign in to follow this  
Followers 0
cletus8269

Oh Teh NOS

7 posts in this topic

A forumite at Gixxer claims he poured two 20 oz. bottles of NOS into his motorcycle's fuel tank because it was "running like crap." There's only one "NOS" that comes in 20 oz. sizes — the energy drink. Forum troll or honest-to-goodness recollection of an epic failure? You decide.

Although we're not positive if this is a forum troll or an honest-to-goodness recollection of an epic failure, but here's the breakdown from the top. Catch the thread here.

Gixxer.com user/Rainman "sti2gsxr" started off the party by posting about some mechanical issues he's been having recently:

My bike was running like crap on my way home from work so I stopped at a gas station to get some NOS. I poured in 2 bottles and rode it home. Well I don't think it helped because it ran even worse on the way home and now it won't start. Any ideas?

Sti2gsxr proceeds to describe the two 20 oz. bottles that he poured directly into his gas tank, which is a dead on account of the popular energy drink, not the fuel additive. The thread spirals out of control after that; harnessing the power of the internet to spread his feat over the entire spectrum of car forums, drawing enthusiasts from every orifice of the digital world, including 4Chan.

Speaking of 4Chan, one of its illustrious members decided it proper to create a comic strip in honor of this special occasion. We've included it to the left as it is nearly essential to the enjoyment of this cavalcade of hilarity.

This spectacle went as far as earning a spot in Wikipedia under the NOS entry. Oh how quickly an act can go from a huge personal failure, to forum fuel, and eventually to document historical event.

custom_1242929636250_NOSFFFFUUUUUUU.jpg

jalopnik article

link to the thread

0

Share this post


Link to post
Share on other sites

LMFAO!!!

That guy just became an hero.

0

Share this post


Link to post
Share on other sites

:rotflmao:

0

Share this post


Link to post
Share on other sites

People do stupid things...similar post happened awhile back on a Mustang Forum. IIRC the guy tried to put sand through his motor to port and polish the valves in his cylender heads.

Chris

0

Share this post


Link to post
Share on other sites
People do stupid things...similar post happened awhile back on a Mustang Forum. IIRC the guy tried to put sand through his motor to port and polish the valves in his cylender heads.

Chris

That one originated on an Audi forum back around 2001, the guy eventually fessed up to it being a hoax.

0

Share this post


Link to post
Share on other sites

As Ron White would say, "You can't fix stupid."

But hell, that damned thread crashed my MAC!

0

Share this post


Link to post
Share on other sites

Your content will need to be approved by a moderator

Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   You have pasted content with formatting.   Remove formatting

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

Sign in to follow this  
Followers 0